FTB Installation Guide 2.0 For 1.7.10 [OLD]

  1. Download the FTB Launcher here. Windows: exe, OSX: app, Linux: jar

  2. Open up the launcher and click 3rd Party Packs. Click Pack Codes and type in wlr and then click enter. You should now have WanderLust Reloaded. Make sure it is selected (version 1.2.3) and launch the game. Wait for it to get to the title screen and feel free to edit any of your settings.

  3. Exit out of FTB after that and reopen the FTB Launcher. Go to 3rd Party Packs and make sure WanderLust Reloaded is selected. Click Edit Modpack, then in the Disabled Mod list enable all the mods except Opis, ModularTurrets, YABM, admincommandtoolbox and worldedit. (If you do not want a minimap then do not enable Journeymap).

  4. Now in the Enabled Mod list look for eirairc-mc and Mystcraft disable them.

  5. Now there’s multiple ways to do this next part, but this is the easiest way you can get to the WanderLust folder. If you are still inside the Edit Modpack part there is a button at the bottom left called Open Folder. Click it and it will open the mods folder for WanderLust, now you can go into the minecraft folder by clicking it at the top.

  6. Now exit out of the FTB Launcher, or else you won’t be able to edit. In your folder you have open now, go into the configs folder. Download these files (use ones down below) and merge/replace the ones in WanderLust with the ones you just downloaded.

IMPORTANT: For now, use these files:

  1. Replace Chisel manually by deleting the one. Add in the one from the files. Add in both of the other files as they add powersuits.

  2. Open up the launcher again, go to WanderLust Reloaded, click launch and have some fun on the server!

Additional things:

Having too many issues modding the modded mod? Download all of the WLR file here

Back-up of mods in case of emergency here.

With Journeymap, it’s a bit laggy to begin with and I recommend that you change some options. When you login to the server or single player world press J. This will open up the whole map, but for the first time it should let you edit things. If it doesn’t go straight to the options, then in the whole map in the top right there should be a button that is called options, click it. Now in here each of the options are drop downs. Click one and you can edit the corresponding settings. Now for the minimap I would recommend only having it show players as
having everything else clutters your minimap and starts to lag your game. You can also remove the beacon waypoints and just have a symbol. (Disable Rotational beacons, stationary beacons). The rest is up to your preference.

For Dual-Wielding, the default key is R, but that key bind is with something else, so you’ll either have to change the Dual-Wielding key or the other mod’s key, your choice.

If you have any problems or questions, post here and someone will attempt to help you out on here or TeamSpeak.

If you are experiencing performance issues, try FastCraft. Add this mod in the same way you did earlier, it should massively increase your FPS.


Also should we unpin and delete the old thread?

Locked, unstickied the other topic and stickied this topic.

[left] ------Update------

Main post has already been changed, but I’ll make another post for others to see. You will be needing to disable HQM-The Journey (4.2.1) as while I was trying to get it to work I accidentally enabled Hardcore mode… and there is no way to disable it through the mod or the configs so… yeah. Sad thing is even that didn’t get the book working, so for now it’s just been disabled. Sorry![/left]
[left] ------Update 2------[/left]
[left]You will need to update a mod called Random things. You can download it here. You will be downloading the version 2.2.1, disable or remove the 2.1.9 version.[/left]
[left]Server works, new map, another fresh start with Biomes O Plenty.

We’re currently working on updating the server! As of yet it isn’t up.

Is there gonna be new mods or mods being updated or anything else?

It’s two versions of the pack newer, so yes, there will be many new files needed. Most likely, we will just have people DL the new pack by default, then modify it as needed.

At the moment the instructions are slightly incorrect. I’m still not sure if Forestry and RandomThings need to be kept at the pack’s default version or changed.

ok sounds good. any updates on when the server will be fixed?

You still have to change the both of them. The Forestry download is the same, but Random Things you will need the newer version (2.2.2). I’ll edit the post right now.

Configs are going to be different, as Kyle was working on them from scratch last night. They have not been added to the post yet either.

No clue. Hopefully soon though.


Anything IRC related. Just found config folder really.

OPIS - Should be optional for users

I ran into the same bug as Crass and the others. The server bugs out as it tries to adapt to the map you had going. Testing with a new map works fine…

So… server is up, but with a new map. I restored everyone’s player data, so they should have their stuff. Maybe we can test more with restoring chunks? Specifically the big file ones (aka the bases).

Any console errors/crashes?

how may times is the map gonna be reset cos we cant jus start again and again

We’re trying to see if we can restore players buildings/ items. Items will be reimbursed, as I’m sure many people don’t want to start all over again. Player data was also saved, so levels in AM2, and research in Thaumcraft are saved.

The map itself is harder to keep, we want to keep it, it’s just the mods dislike us wanting to do so sadly…

This is a issue with starting a new ftb server. As with tekkit, unleashed and monster there were many lost maps and item resets in the first few months of running the server as we try and fix bugs and update things.

Modpacks dont always work straight out of the gate as they might suggest, some fiddling is required to get a stable server to run on. Items lost will often be reimbursed to counter the frequent restarts if maps are none recoverable during a update.

We ask you to be patient whilst things get set up and smoothed out during the initial launch phase.

Has someone reported the issues on the WLR thread? None of the updates were map-breaking, so it shouldn’t have been an issue…

are we free to enter the server again? or is it better if we wait?

I believe I have finished fixing the map. Server is up and running, but player’s data is gone for now. We will be reimbursing items you had on you and I will manually update your thaumcraft and other data.

Please log in and post if you need me to add in your research. I will delete your post after I fix it.

Also, I can see what you had, so no asking for hundreds o diamonds!

Wait, so do you need to know what was in my inv? because I totally had 300 stacks of diamond blocks :stuck_out_tongue:

It appears like there are some issues with the server:
Rejecting connection SERVER:
FMLMod:ProjRed|Expansion{}, (client does not have this)
FMLMod:BuildCraft|Core{6.2.2}, (client has this)
FMLMod:ProjRed|Exploration{}, ( client does not have this)
FMLMod:CarpentersBlocks{3.3.3}, (client has this)
FMLMod:BuildCraft|Energy{6.2.2}, (client has this)
FMLMod:BuildCraft|Builders{6.2.2}, (client has this)
FMLMod:BuildCraft|Transport{6.2.2}, (client has this)
FMLMod:ProjRed|Transportation{}, (client does not have this)
FMLMod:EnderTech{1.7.10-}, (client has this)
FMLMod:ProjRed|Core{}, (client has this)
FMLMod:RandomThings{2.2.0}, (client has this)
FMLMod:ttCore{MC1.7.10-0.1.0-40}, (?)
FMLMod:Forestry{}, (client has this)
FMLMod:BuildCraft|Silicon{6.2.2}, (client has this)
FMLMod:ProjRed|Compatibility{}, (client has this)
FMLMod:GraveStone{2.10.2}, (client has this)
FMLMod:ProjRed|Illumination{}, (client does not have this)
FMLMod:extracells{2.1.13}, (client has this)
FMLMod:ProjRed|Integration{}, (client has this)
FMLMod:RIO{1.7.1}, (?)
FMLMod:simplyjetpacks{1.2.0}, (client has this)
FMLMod:BuildCraft|Factory{6.2.2}, (client has this)
FMLMod:Botania{r1.3-140}, (client has this)
FMLMod:ProjRed|Transmission{} (client does not have this)

There’s a serious issue with client and server not having the same mods.

You need to update WLR to 1.1.7, I will be updating the post with EVERYTHING you need to do right away.

EDIT: Done, Installation Tutorial should be up to date now.